BETA

4th May 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [04/05/19 10:56 PM] with 'Major Outage'

Issue has been resolved at [04/05/19 11:01 PM]