BETA

23rd July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [22/07/18 09:33 PM] with 'Partial Outage'

Issue has been resolved at [22/07/18 09:35 PM]