BETA

4th May 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [04/05/19 10:10 PM] with 'Major Outage'

Issue has been resolved at [04/05/19 10:14 PM]