BETA

22nd July 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [22/07/18 08:31 PM] with 'Partial Outage'

Issue has been resolved at [22/07/18 08:34 PM]