BETA

22nd July 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [22/07/18 08:09 PM] with 'Major Outage'

Issue has been resolved at [22/07/18 08:11 PM]