BETA

4th May 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [04/05/19 08:03 PM] with 'Partial Outage'

Issue has been resolved at [04/05/19 08:07 PM]