BETA

14th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [14/03/19 02:26 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/03/19 04:56 PM]