BETA

22nd July 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [22/07/18 11:18 AM] with 'Partial Outage'

Issue has been resolved at [22/07/18 11:19 AM]