BETA

4th May 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [04/05/19 04:32 PM] with 'Major Outage'

Issue has been resolved at [04/05/19 04:33 PM]