BETA

22nd July 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [22/07/18 10:33 AM] with 'Partial Outage'

Issue has been resolved at [22/07/18 10:34 AM]