BETA Singapore cluster       Mumbai cluster

14th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/03/19 02:07 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [14/03/19 04:56 PM]