BETA

22nd July 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [22/07/18 04:31 AM] with 'Partial Outage'

Issue has been resolved at [22/07/18 04:37 AM]