BETA

27th June 2016

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [27/06/16 05:10 PM] with 'Partial Outage'

Issue has been resolved at [27/06/16 05:11 PM]