BETA

21st July 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [21/07/18 06:10 PM] with 'Partial Outage'

Issue has been resolved at [21/07/18 06:12 PM]