BETA

21st July 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [21/07/18 05:57 PM] with 'Major Outage'

Issue has been resolved at [21/07/18 05:58 PM]