BETA

14th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/03/19 01:12 PM] with 'Partial Outage'

Issue has been resolved at [14/03/19 02:03 PM]