BETA

21st July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [21/07/18 03:18 PM] with 'Partial Outage'

Issue has been resolved at [21/07/18 03:19 PM]