BETA

21st July 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [21/07/18 10:39 AM] with 'Partial Outage'

Issue has been resolved at [21/07/18 10:40 AM]