BETA

21st July 2018

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [21/07/18 02:42 AM] with 'Partial Outage'

Issue has been resolved at [21/07/18 02:44 AM]