BETA

20th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [20/07/18 06:21 PM] with 'Partial Outage'

Issue has been resolved at [20/07/18 06:22 PM]