BETA

4th May 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [04/05/19 12:46 AM] with 'Major Outage'

Issue has been resolved at [04/05/19 12:49 AM]