BETA

5th April 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [05/04/17 07:09 PM] with 'Major Outage'

Issue has been resolved at [05/04/17 07:11 PM]