BETA

3rd May 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [03/05/19 10:01 PM] with 'Major Outage'

Issue has been resolved at [03/05/19 10:02 PM]