BETA

20th July 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [20/07/18 12:35 PM] with 'Partial Outage'

Issue has been resolved at [20/07/18 12:36 PM]