BETA

20th July 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [20/07/18 10:15 AM] with 'Partial Outage'

Issue has been resolved at [20/07/18 10:16 AM]