BETA

20th July 2018

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [20/07/18 09:11 AM] with 'Partial Outage'

Issue has been resolved at [20/07/18 09:21 AM]