BETA

20th July 2018

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [20/07/18 09:09 AM] with 'Major Outage'

Issue has been resolved at [20/07/18 09:25 AM]