BETA

18th July 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [18/07/18 05:11 PM] with 'Partial Outage'

Issue has been resolved at [18/07/18 05:13 PM]