BETA

18th July 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [18/07/18 05:11 PM] with 'Major Outage'

Issue has been resolved at [18/07/18 05:13 PM]