BETA Singapore cluster       Mumbai cluster

30th April 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [30/04/19 10:37 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [16/05/19 10:23 PM]