BETA

18th July 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [18/07/18 04:28 PM] with 'Major Outage'

Issue has been resolved at [18/07/18 04:30 PM]