BETA

30th April 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [30/04/19 10:32 AM] with 'Partial Outage'

Issue has been resolved at [30/04/19 10:34 AM]