BETA

18th July 2018

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [18/07/18 04:26 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [29/08/18 02:40 AM]