BETA

18th July 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [18/07/18 10:50 AM] with 'Major Outage'

Issue has been resolved at [18/07/18 10:52 AM]