BETA

18th July 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [18/07/18 12:14 AM] with 'Major Outage'

Issue has been resolved at [18/07/18 12:59 AM]