BETA

17th July 2018

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [17/07/18 11:56 PM] with 'Major Outage'

Issue has been resolved at [18/07/18 12:06 AM]