BETA

17th July 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [17/07/18 04:58 PM] with 'Major Outage'

Issue has been resolved at [17/07/18 04:59 PM]