BETA

16th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [16/07/18 08:17 AM] with 'Partial Outage'

Issue has been resolved at [16/07/18 08:19 AM]