BETA

30th April 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [30/04/19 09:35 AM] with 'Partial Outage'

Issue has been resolved at [30/04/19 09:37 AM]