BETA

30th April 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [30/04/19 09:23 AM] with 'Partial Outage'

Issue has been resolved at [30/04/19 09:26 AM]