BETA

16th July 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [16/07/18 06:39 AM] with 'Partial Outage'

Issue has been resolved at [16/07/18 06:40 AM]