BETA

16th July 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [16/07/18 06:39 AM] with 'Major Outage'

Issue has been resolved at [16/07/18 06:40 AM]