BETA

16th July 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [16/07/18 06:36 AM] with 'Partial Outage'

Issue has been resolved at [16/07/18 06:37 AM]