BETA

15th July 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [15/07/18 07:44 PM] with 'Major Outage'

Issue has been resolved at [15/07/18 07:45 PM]