BETA

15th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [15/07/18 11:55 AM] with 'Partial Outage'

Issue has been resolved at [15/07/18 11:57 AM]