BETA

14th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/07/18 06:54 PM] with 'Partial Outage'

Issue has been resolved at [14/07/18 06:56 PM]