BETA

14th July 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [14/07/18 11:54 AM] with 'Major Outage'

Issue has been resolved at [14/07/18 11:55 AM]