BETA

14th July 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [14/07/18 10:48 AM] with 'Partial Outage'

Issue has been resolved at [14/07/18 10:51 AM]