BETA

13th July 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [13/07/18 11:06 PM] with 'Partial Outage'

Issue has been resolved at [13/07/18 11:08 PM]