BETA

13th July 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [13/07/18 05:04 PM] with 'Major Outage'

Issue has been resolved at [13/07/18 05:06 PM]